HeapStats/Analyzer-version1

From IcedTea

Jump to: navigation, search
[HeapStats User Manual Table of contents]

This page is the online manual about HeapStats 1.x analyzer. If you want to read the HeapStats 2.x manual, go to HeapStats/Analyzer-version2

Contents

1 Analyzer

The analyzer loads snapshot files that were output by the agent, analyzes the information collected in them, and displays analysis results graphically. It narrows down the range of data to be analyzed in terms of period and class, and analyzes the narrowed-down data to identify causes of faults. In addition, the analyzer outputs collected information as a CSV file, a format that is easy for external tools to use.

1.1 System requirements

The hardware and software requirements for the analyzer are as follows:

Hardware requirements
  • CPU: Specifications that are recommended for the OS and JDK used ・Memory: 2 GB or more
  • Hard disk drive: 256 MB or more free space
  • Display: resolution of 1,024×768 or higher; HighColor (65,536 colors) or higher
Software requirements
  • OS: Linux or OS X (Mac) on which GUI, such as an X Window System, runs, or Microsoft Windows Vista or later
  • Java: OpenJDK 6 or later, or Java SE 6 or later
  • Library: JFreeChart 1.0.13 or later, and JgraphX 2.5 or later Note)

Note) If JDK6 is used for Java, it is necessary to use JGraphX (version 2.5.0.3 or earlier) that supports JDK6.

1.2 Installing the analyzer

The analyzer can be installed in two ways:

  • Install the binary file
  • Build the source code and install the result.

These are described below.

1.2.1 Installing the binary file

The analyzer is a pure Java application, which is provided as an executable JAR file. Download a zip-archived analyzer (heapstats_analyzer-x.y.z.zip) from the HeapStats Community site (http://icedtea.classpath.org/wiki/HeapStats/jp), and expand it at any directory you select. Note that the analyzer can operate independently of the agent. Therefore, the analyzer can be installed and used in a machine different from the machine in which the agent is installed.

Create a lib directory in the directory in which the analyzer was expanded, and place the libraries of JFreeChart and JGraphX in it. These libraries can be obtained from the following:

JFreeChart
Download site: http://sourceforge.net/projects/jfreechart/files/
Files to be downloaded: jfreechart-x.y.z.jar (the latest version is version 1.0.19 as of March 20, 2015), and jcommon-x.y.z.jar (the latest version is version 1.0.23 as of March 20, 2015).
JGraphX
Download site: http://www.jgraph.com/jgraphdownload.html
File to be downloaded: jgraphx.jar (the latest version is version 3.1.2.1 as of March 20, 2015. However, if JDK6 is used for Java, use version 2.5.0.3 or earlier.)

The directory structure after the libraries are placed is as follows:

Heapstats┬lib┬jfreechart-x.y.z.jar
         │   ├jcommon-x.y.z.jar
         │   ├jgraphx.jar
         ├filterDefine.xsd
         ├heapstats.jar
         ├heapstats.properties
         ├howtouse.txt
         ├howtouse_ja.txt

This completes the installation of the analyzer using a binary file.

1.2.2 Building the source code and installing the result

In a manner similar to what was described in "Building the source code and installing the result" download an archive file of the source code from the HeapStats Community site. Expand the archive file by executing the following command in the directory in which the downloaded archive file is stored.

# tar xvfz heapstats-x.y.z.tar.gz

Fig. 4-1 Expanding the archive file

Create a lib directory in the directory in which the archive file was expanded, and place the libraries of JFreeChart and JGraphX (jcommon-x.y.z.jar and jfreechart-x.y.z.jar, jgraphx.jar) in it. For information about sites from which the libraries of JFreeChart and JGraphX can be obtained, refer to "Installing the binary file."

Next, build the source code using an ant command.

# cd heapstats-x.y.z/analyzer
# ant

Fig. 4-2 Building the analyzer

This completes the installation of the analyzer by building the source code.

1.3 Launching the analyzer

Launch the analyzer by executing a "java -jar heapstats.jar" command. If you are using Windows OS, you can also launch the analyzer by double-clicking "heapstats.jar." If you are using Linux, launch the analyzer from a command line. When the analyzer is launched, the window shown in Fig. 4-3 appears.

Fig. 4-3 Window that appears at the launch of the analyzer
Fig. 4-3 Window that appears at the launch of the analyzer

1.4 Operation

1.4.1 Loading log files

The analyzer first loads log files that were collected by the agent. This enables the analyzer to begin to use the functions described in "Resource Data" and "Log Detail Data." If you want to launch the analyzer in a machine other than the one to which the agent is attached, get the log file in advance using ftp, etc. If you want to launch the analyzer in a machine to which the agent is attached, and if the attached Java application is running, load copies of the log files. To load log files (CSV format). click the [File selection] button in the red frame in Fig. 4-4. Then, an [Open] dialog appears.

Fig. 4-4 [File selection] button
Fig. 4-4 [File selection] button

In the [Open] dialog shown in Fig. 4-5 , select a log file and click the [Open] button. You may select multiple log files.

Fig. 4-5 [Open] dialog (for selecting log files)
Fig. 4-5 [Open] dialog (for selecting log files)


The default filename of a log file is heapstats_log.csv. Note that "dot + numeral" may be appended to the filename by the logrotate function (Refer to "Setting logrotate"). When a selected log file is loaded, the log filename (in the blue frame) and the log collection period (in the green frame) are displayed as shown in Fig. 4-6. Select the period for which you want to analyze the logs in [Period selection], and then click the [OK] button in the red frame in Fig. 4-6.

Fig. 4-6 After log files are loaded
Fig. 4-6 After log files are loaded

After the [OK] button is clicked, a progress bar as shown in Fig. 4-7 is displayed until information about all the tabs is displayed.

Fig. 4-7 Progress bar that appears while log files are being loaded
Fig. 4-7 Progress bar that appears while log files are being loaded

You can select a date from the pull-down menu of [Period selection]. You can also select a date by entering characters. Each time you enter or delete a character, candidate dates appear (incremental search). An example of incremental search in [Period selection] is shown in Fig. 4-8.

Fig. 4-8 Incremental search used for selecting a period
Fig. 4-8 Incremental search used for selecting a period

1.4.2 Resource Data

Information about the items shown in Table 4-1 Chart display items" is displayed graphically. By studying this information, you can ascertain whether there were any problems with the CPU, memory or threads during the selected period.

Table 4-1 Chart display items
Chart Display item Description
JavaCPU

(Java CPU usage)

user Ratio of the user’s usage to the CPU usage of the Java application
system Ratio of the system’s usage to the CPU usage of the Java application
SystemCPU

(System CPU usage)

user Cumulative amount of the CPU time consumed for the user’s processing of the entire system
nice Cumulative amount of the CPU time consumed for the user’s processing of the entire system in a low priority condition
system Cumulative amount of the CPU time consumed for system processing of the entire system
idle Cumulative amount of the CPU time consumed for idle time of the entire system
I/O Cumulative amount of the CPU time consumed for I/O processing waiting time of the entire system
irq Cumulative amount of the CPU time consumed for interruption processing of the entire system
softirq Cumulative amount of the CPU time consumed for software interruption processing of the entire system
steal Cumulative amount of the CPU time consumed for the processing of other virtual environments on the same machine
guest Cumulative amount of the CPU time consumed for the processing of virtual guest environments within the system
JavaMemory

(Java memory usage)

RSS(KB) Number of pages on memory (in KByte)
VSZ(KB) Total virtual memory size (in KByte)
Threads threads Number of currently operating threads in the Java application
monitor Number of monitoring conflicts inside Java
safepoint Number of safepoints of the Java application
safepointtime(msec) Duration of the safepoint of the Java application (msec)

[Process Summary] displays the following information:

CPU average
Average CPU usage of the Java application
CPU peak
Peak CPU usage of the Java application
VSZ average
Average virtual memory usage of the Java application (KByte)
VSZ peak
Peak virtual memory usage of the Java application (KByte)
RSS average
Average physical memory usage of the Java application (KByte)
RSS peak
Peak physical memory usage of the Java application (KByte)
Fig. 4-9 Resource Data
Fig. 4-9 Resource Data

1.4.3 Log Detail Data

The fault analysis-related archive file (zip-archived) is expanded, and information therein is displayed. Vertical lines in the charts in the Resource Data indicate the time when information of the fault analysis-related archive file was collected. An example of the display of resource information at the time when the fault analysis-related archive file was collected is shown in Fig. 4-10. Items displayed in Log Detail Data are shown in Table 4-2 List of log data items.

Table 4-2 List of log data items
No. Item name Description
1 FileName Filename of the fault analysis-related archive file
2 CollectionDate Time when a resource exhaustion fault occurred or when a signal was received
3 LogTrigger Log trigger
  • Signal: signal
  • ResourceExhausted: resource exhaustion fault occurrence
  • Deadlock: deadlock detection
4 VmVersion VM version
5 OsRelease OS release information
6 LibCVersion libc version information
7 LibCRelease libc release information
8 VmName VM name
9 ClassPath Class path
10 EndorsedPath Endorsed path
11 JavaVersion Java version number
12 JavaHome JAVA_HOME
13 BootClassPath Boot class path
14 VmArgs VM launch arguments
15 VmFlags VM launch setting options
16 JavaCmd Java option
17 VmTime Elapsed time from VM launch (msec)
18 redhat-release Distribution information file
19 cmdline Process argument file
20 status Process status file
21 smaps Memory mapping information file
22 limits Resource limit information file
23 Socket Socket end point and owner information
24 ThreadDump Thread information displayed when the log trigger has detected a deadlock.
Fig. 4-10 Example of information in the fault analysis-related archive
Fig. 4-10 Example of information in the fault analysis-related archive
Fig. 4-11 Log Detail Data
Fig. 4-11 Log Detail Data

1.4.4 Loading a snapshot file

By loading a snapshot file that was output by the agent, the analyzer can use a variety of the functions described below. To load a snapshot file, click the [File selection] button in the red frame in Fig. 4-12. An [Open] dialog appears.

Fig. 4-12 [File selection] button
Fig. 4-12 [File selection] button

Select one or more snapshot files in the [Open] dialog shown in Fig. 4-13, and click the [Open] button. You may select multiple snapshot files. An example of selecting multiple snapshot files is shown in Fig. 4-13.

Fig. 4-13 [Open] dialog (selection of snapshot files)
Fig. 4-13 [Open] dialog (selection of snapshot files)

The default filename of a snapshot file is heapstats_snapshot.dat. Note that "dot + numeral" may be appended to the filename by the logrotate function. (Refer to "Setting logrotate"). When the snapshot file is loaded, a snapshot filename (in the blue frame) and a snapshot period (in the green frame) is displayed as shown in Fig. 4-14. Select the period for which you want to analyze the snapshot in [Period selection], and then click the [OK] button in the red frame in Fig. 4-14. If there is only one snapshot file, no difference analysis can be carried out. An error dialog, "The start and end times are the same" is displayed, and no analysis is carried out.

Fig. 4-14 After loading a snapshot file
Fig. 4-14 After loading a snapshot file

After the [OK] button is clicked, a progress bar as shown in Fig. 4-15 Progress bar while snapshot is displayed until information about all the tabs is displayed.

Fig. 4-15 Progress bar while snapshot files are being loaded
Fig. 4-15 Progress bar while snapshot files are being loaded

1.4.5 Statistic Chart

Statistical information about snapshots is displayed. "Statistics Chart" displays information for the selected period graphically. You can ascertain whether there were any problems in the heap and metaspace.

"Statistics Chart" displays the following information graphically:
Total Heap Size(KB)
Total heap size (KByte)
New Heap Usage(KB)
Usage of the Young Generation (KByte)
Old Heap Usage(KB)
Usage of the Old Generation Note)(KByte)
GC Time(msec)
GC processing time (msec)

Note) The graph shows the usage for surviving objects only. In this respect, it is different from the graphical display of the GC log.

"Metaspace Chart" displays the following information:
Metaspace Capacity(KB)
Total metaspace size (KByte)
Metaspace Usage(KB)
Metaspace usage (KByte)
"Summary" displays the following information:
SnapShot Count
Number of snapshots taken within the period
GC Count
Number of garbage collections. The total, the number of FullGCs, and the number of YoungGCs are displayed separately.
Latest Heap Usage
Heap usage at the time of the last snapshot (KByte)
Latest Metaspace Usage
Metaspace usage at the time of the last snapshot (KByte)
Max GC Time
Maximum GC processing time within the period (msec)
Min GC Time
Minimum GC processing time within the period (msec)
Fig. 4-16 Statistic Data
Fig. 4-16 Statistic Data

1.4.6 Delta Data

The differences in heap usage and usage rankings are displayed for the selected period.

The "Difference Rank Chart" displays differences in heap usage between pairs of snapshots in descending order. If the label is "Usage", differences in heap usage are displayed in descending order. If the label is "Instance", differences in the number of instances are displayed in descending order. The number of ranks to be display is set in "Setting ranking."

The "Heap Usage Chart" displays the cumulative total of heap usage for each object graphically. The heap usage of objects in high rankings and that of the rest of objects are displayed in separate graphs. If the label is "Usage", heap usages are displayed in descending order. If the label is "Instance", the number of instances are displayed in descending order. The number of ranks to be displayed is set in "Setting ranking."

The "List of objects" displays objects in the first and last snapshots within the selected period in descending order of the difference in heap usage. As shown Fig. 4-20, the colors in the leftmost column are linked to colors used in the "Difference Rank Chart" and the "Heap Usage Chart."

If you click the [Usage] button or the [Number of instances] button, the displays in the "Difference Rank Chart" and the "Heap Usage Chart" are changed accordingly A window displayed after the [Usage] button is click is shown in Fig. 4-17, and a window displayed after the [Number of instances] button is clicked is shown in Fig. 4-18.

"Class Filter" and "Class Search" are described in detail in "Filtering."

Fig. 4-17 Delta Data (sorted according to usage)
Fig. 4-17 Delta Data (sorted according to usage)
Fig. 4-18 Delta Data (sorted according to the number of instances)
Fig. 4-18 Delta Data (sorted according to the number of instances)

1.4.7 Snapshot Data

Information about the specified snapshot is displayed. In the initial display, the oldest snapshot within the selected period is displayed. When you click the graph part of the "Heap Usage Chart" or the "Difference Rank Chart" in the "Statistics Chart" or "Delta Data", the snapshot at that point is displayed. A white vertical line appears on the part where you have clicked on a Chart.

"Snapshot Data" displays the following information.
Date
Date and time of the snapshot (format: yyyyMMdd HH:mm:ss)
Entries
Number of entries in the list of objects
Total Heap Usage
Total heap usage
Snapshot Cause
Cause of taking the snapshot (Displayed information: GC, DataDumpRequest, Interval)
GC Cause
Cause of the GC (Refer to Table 5-2)


The "Heap Usage Chart" displays heap usage in a pie chart. The percentages of heap usage of objects in high ranks and the remaining objects are displayed separately. If filtering ("Filtering") is applied in the Delta Data, the remaining objects (shown in blue in Fig. 4-19) are not displayed in the pie chart. How to set the number of ranks that will be displayed is described in "Setting ranking."

The "List of objects" displays all the objects that had been loaded in the memory when the snapshot concerned was taken. The colors at the leftmost column in the table are linked to the colors used in the "Heap Usage Chart." An example with "[C" is shown in Fig. 4-19.

Fig. 4-19 Snapshot Data
Fig. 4-19 Snapshot Data

The same color is assigned to each class in the "Delta Data" tab and the "Snapshot Data" tab of the analyzer.

Fig. 4-20 The same color is assigned to the same class
Fig. 4-20 The same color is assigned to the same class

1.4.8 Reference Data

References between objects are displayed using the selected object as the origin. To specify an object that will serve as the origin, double-click the object you want to specify in the "Delta Data" or "Snapshot Data." The selected object is shown as a red ellipse in the Reference Data (Fig. 4-21). If you have selected an object in the " Delta Data", the references displayed are those at the time when the latest snapshot was taken within a period selected in the selection information. If you have selected an object in the "Snapshot Data", the references displayed are those at the time when the currently displayed snapshot was taken.

Fig. 4-21 Reference Data
Fig. 4-21 Reference Data

You can make various settings to display reference objects in different ways. For example, you can display them with references represented with directions toward parent objects or with references represented with directions toward child objects. You can sort reference objects according to the number of instances, or the amount of usage. You can choose to display only the objects that are in higher positions in the sort result. You can set the number of ranks to display in the way described in "Setting ranking."

An example of expansion of a reference object is shown in Fig. 4-22. Two numbers are displayed on each of the lines drawn between objects. The upper number indicates the number of reference instances, and the lower number indicates memory usage. When you hover the mouse over these numbers, detailed numbers are displayed. Note that the number of reference instances is the number of references and not the number of instances. If there are a number of references, these are counted. Therefore, the number of reference instances is greater than the number of actual instances. Therefore, it is advisable to focus your attention on the percentage rather than on the absolute number of reference instances.

Fig. 4-22 Expansion of a reference object
Fig. 4-22 Expansion of a reference object

1.4.9 Filtering

What filtering does is to exclude specific classes to narrow down classes to only a certain class path in the "Delta Data", "Snapshot Data" and "CSV Output." You can specify filtering on the window of the "Delta Data" tab.

1.4.9.1 Class filter

The class filter is used to exclude specific classes (classes that are specified in the name in Table 4-5 "Tags used in a filtering setting file"). Click the [Add filter] button in the red frame in Fig. 4-23 to display an [Open] dialog, which is used to select a filtering setting file (XML).

Fig. 4-23 Delta Data
Fig. 4-23 Delta Data

Select a filtering setting file in the [Open] dialog box, and click the [Open] button.

Fig. 4-24 Dialog for selecting a filtering setting file
Fig. 4-24 Dialog for selecting a filtering setting file

To carry out filtering, click the [OK] button in Fig. 4-25 while keeping check marks in the "Exclusion" column (in a blue frame) in the list of filters. The filters against which no check mark is placed in the "Exclusion" column are excluded from filtering.

Fig. 4-25 After a class filter is applied
Fig. 4-25 After a class filter is applied

If you want to remove class filters and clear the list of filters, click the [Clear] button.

Fig. 4-26 After class filters are removed
Fig. 4-26 After class filters are removed
1.4.9.2 Class search

A class search is carried out when you want to find a specific class path. Enter a part of a class path in the class path input part in the red frame in Fig. 4-27. Each time you enter or delete a character in the class path input part, class paths that match the input character strings are displayed within the blue frame in Fig. 4-27. The class paths that are subject to this search are all class paths within the snapshot selection period minus those excluded in class filtering.

Fig. 4-27 Entering characters in class search
Fig. 4-27 Entering characters in class search

When you click the [OK] button at the bottom while keeping any number of displayed classes selected, information about only the selected classes is displayed. When classes are selected, the window shown in Fig. 4-28 appears. Information about the selected classes is shown as in Fig. 4-29. You can manually select any displayed class paths, or click the [Select All] button to select all class paths. When you click the [Select All] button, the button name changes to [Deselect All]. You can deselect all class paths by clicking the [Deselect All] button. When you click the [Clear] button, the narrowing down of classes is canceled, and information about all the classes is displayed. However, information about those classes that have been excluded by class filtering is not displayed.

Fig. 4-28 Selecting class paths
Fig. 4-28 Selecting class paths
Fig. 4-29 After execution of class search
Fig. 4-29 After execution of class search

1.4.10 Setting ranking

You can update the number of ranks of the objects that will be displayed in the "Difference Rank Chart" and the "Heap Usage Chart" in the "Delta Data" tab, the "Heap Usage Chart" in the "Snapshot Data" tab, and the "Reference Data" as follows.

When you click "Option (O) – Rank Setting (R)" in the menu, a "Ranking setting" dialog appears. Enter an integer in the ranking setting input box in Fig. 4-30, and click the [Accept] button. Your ranking setting is incorporated when you click the [OK] button in the red frame in Fig. 4-31.

Fig. 4-30 Ranking setting
Fig. 4-30 Ranking setting
Fig. 4-31 Incorporating ranking setting
Fig. 4-31 Incorporating ranking setting

1.4.11 CSV file output

Two types of CSV files are output. One type contains heap usage and the number of instances for each snapshot of each object. The other type contains GC statistical information for each snapshot. To specify the output period, you can select either the entire period of all the snapshot files loaded or a period selected in "Period Selection." Make the following menu selections to output a CSV file.

  • Heap usage: option (O) – CSV output (C) - Heap usage (H) – All (A) or Select (S)
  • GC statistical information: option (O) – CSV output (C) - GC statistical information (G) All (A) or Select (S)
Fig. 4-32 CSV file output menu (All)
Fig. 4-32 CSV file output menu (All)

If you want to output information about all the snapshots to a CSV file, click the "All (A)" (red frame in Fig. 4-32). If you want to specify the period for the snapshots that you want to output to a CSV file, select "Period Selection" in "Selection information" and enter the start date and time (red frame in Fig. 4-33) and the end date and time (blue frame in Fig. 4-33). Make sure that the start time is earlier than the end time.

Fig. 4-33 Selecting a period for outputting a CSV file
Fig. 4-33 Selecting a period for outputting a CSV file

After you have selected a period, click the "Select (S)" (red frame in Fig. 4-34).

Fig. 4-34 CSV file output menu (Select)
Fig. 4-34 CSV file output menu (Select)

The progress bar shown in Fig. 4-35 is displayed while a CSV file is being output. When the output of a CSV file is complete, click the [Accept] button shown in Fig. 4-36.

Fig. 4-35 Progress bar during CSV file output
Fig. 4-35 Progress bar during CSV file output
Fig. 4-36 Message dialog announcing the completion of the output of a CSV file
Fig. 4-36 Message dialog announcing the completion of the output of a CSV file

The header of a heap usage file is shown in Table 4-3. The header of a GC statistical information file is shown in Table 4-4.

Table 4-3 Header of a heap usage CSV file
No. Name Description
1 Tag Hexadecimal numeral assigned to the JVMTI
2 Name Class paths
3 yyyyMMdd HH:mm:ss_instances The number of instances of an object is displayed for each snapshot.
4 yyyyMMdd HH:mm:ss_total size The heap usage of an object is displayed for each snapshot.
Table 4-4 Header of a GC statistical information CSV file
No. Name Description
1 SnapShot Date Time when the snapshot is taken. Time is expressed in the following format: yyyyMMdd HH:mm:ss
2 Full GC Count The number of FullGCs at the time when the snapshot was taken is output.
3 Young GC Count The number of YoungGCs at the time when the snapshot was taken is output.
4 New Heap Usage Young Generation heap usage at the time when the snapshot was taken is output.
5 Old Heap Usage Old Generation heap usage at the time when the snapshot was taken is output.
6 Total Heap Size Total heap size at the time when the snapshot was taken is output.
7 GC Cause The cause of the GC is output. In the case of a periodic snapshot without any cause of a GC, or in the case of a snapshot taken at a dump request, "-" (hyphen) is output.
8 GC Time GC processing time is output. In the case of a period snapshot without any GC processing, or in the case of a snapshot taken at a dump request, "-" (hyphen) is output.

1.4.12 Tab separation

If you click "Option (O) - Tab Display (T)" in the menu in the tab of "Statistic Chart", "Delta Data" or "Snapshot Data", the window changes to a dialog display. If you want to go back to a tab display, click "Option (O) - Tab Display (T)" in the menu.

Fig. 4-37 Main window
Fig. 4-37 Main window
Fig. 4-38 Resource Data
Fig. 4-38 Resource Data
Fig. 4-39 Log Data
Fig. 4-39 Log Data
Fig. 4-40 Statistic Chart
Fig. 4-40 Statistic Chart
Fig. 4-41 Reference Data
Fig. 4-41 Reference Data
Fig. 4-42 Delta Data
Fig. 4-42 Delta Data
Fig. 4-43 Snapshot Data
Fig. 4-43 Snapshot Data

1.4.13 Switching the language

The default language is English. You can switch to Japanese by changing the property. Once you have changed the property, you must restart the analyzer.

  • Property file: heapstats.properties
    • Select English: language=en
    • Select Japanese: language=ja

1.5 External settings

1.5.1 Creating a filtering setting file

You can create a filtering setting file, which is used in "Delta Data" as follows. All tags in a filtering setting file are mandatory. The tags are described in Table 4-5. An example of a filtering setting file is shown in Fig. 4-44.

Table 4-5 Tags used in a filtering setting file
No. Tag name Description
1 <filter name> Set the name that will be displayed in the filter name of the class filter. The name shall be unique among all the filtering files loaded. You can set either English or Japanese.
2 <visible> Specify whether you want to check-mark the "Exclusion" of a class filter.
  • true: check-marked
  • false: Not check-marked
3 <name> Specify the class path you want to exclude with a "/". If "*" is set at the end of a class path, the characters that follow are treated as a wild card. "*" can be placed at any point in a class path provided it is at the end. Multiple "*" can be set.
<?xml version="1.0" encoding="UTF-8"?>
<filters>
 <filter name="Tomcat">
   <visible>false</visible>
 <classes>
<name>org/apache/tomcat/InstanceManager</name> <name>org/apache/tomcat/util* </name>
 </classes>
 </filter>
 <filter name="PostgreSQL">
   <visible>true</visible>
 <classes>
  <name>org/postgresql/*</name>
 </classes>
 </filter>
 <filter name="java">
   <visible>true</visible>
 <classes>
  <name>java/io/*</name>
  <name>java/util/array*</name>
 </classes>
 </filter>
</filters>

Fig. 4-44 Example of a filtering setting file

The window that will be displayed when the filtering setting file shown in Fig. 4-44 is loaded is shown in Fig. 4-45.

Fig. 4-45 The window displayed when a filtering setting file is loaded
Fig. 4-45 The window displayed when a filtering setting file is loaded

1.6 Displaying messages

Messages displayed by the analyzer and how to respond when these messages are output are described in "Messages output by the analyzer."


[HeapStats User Manual Table of contents]
Personal tools